TOS not working for RUT

Michael B

Member
Starting this morning my TOS doesn't work for RUT. Option chains don't have the usual shading for ITM / OTM strikes. Analyze tab doesn't show any trade. However all works fine for SPX or other underlyings. Tried restarting / rebooting and no luck.
 

Michael B

Member
This is how option chains currently look like for example. They are not centered on ATM and can't scroll either. Meanwhile I noticed data for SPX is from Nov 27 and analyze tab works based on that data. Both RUT and SPX charts stop at Nov 27.
I have a 2nd computer showing the same issue, so I know it's not a computer problem at my end.
1575049588059.png
 

status1

Member
I see what you mean
I am not sure if they have different server in different parts of the country and maybe it's only messed up in your area
Here is my view and as you can see it's working fine
 

Attachments

status1

Member
Did you try deleting the usergui folder ?
That's usually what they suggest when something is wrong with the platform
Not having the right quotes is one thing which could be due to what they were saying but I don't think that should affect the shading of the options so you may have an issue with the platform in addition to the quotes
You may also want to try uninstall/install TOS just to make sure there are no platform issues
 

garyw

Member
Michael's symptoms appeared as no current pricing was being observed. Curious if it is showing "Connected" and "Realtime data" with the proper date up in the upper left corner?
1575127625465.png
Testing using PaperMoney, may provide an additional data point to help determine what may be occurring. Also testing with other accounts to insure all have same symptom may be of value, in case issue relates to only a single account.
Also, if you are running a new VPN, or one that has recently been "upgraded?", you may want to disable it (the VPN) and retry TOS, to insure that is not muddying the waters. -- However, since two machines have similar issue, the VPN would have to be from your router (unless installed on both machines).
Note: You may wish to rule out a switch or router between your impacted PC's and the WAN connection. I once had a LinkSys switch fail which resulted in a similar symptom (Not with TOS, but other service).
 

Michael B

Member
Guys, thank you for trying to help.
1. I'm reluctant to uninstall and reinstall. I fear all sort of hiccups that may happen or not.
2. I only use TOS paper money. My real trades are with IB, but their monitoring capabilities are practically inexistent.
3. I don't use VPN when at home.
4. Starting today RUT option chains look normal and analyze tab works and displays the last day (11/29) price.
5. Charts for indexes still stop at 11/27.
 

garyw

Member
Interesting... Can you check your upper right-hand info and compare to my PaperMoney info? You may have it configured differently....
1575138912221.png
This is from my PaperMoney. Note "Realtime data", curious if yours may be "Delayed data"!
BTW: My PaperMoney also reports the indexes up to only 11/27! Seems you may have discovered a new undocumented PaperMoney feature! :-(
 

Michael B

Member
For me it's on the upper left corner.
1575148646073.png
And when I click on Realtime data it shows this:
1575148739490.png

So your indexes are also shown up to 11/27... Well, I doubt my chart indexes were always one day delayed and I didn't notice. But on the other hand I will soon be 65, so chances are I may have some issues myself.
This is how a RUT simulation currently looks like. The 1624.50 value shown for RUT is the closing for 11/29, so analyze tab seems to be working properly now. Charts however still show 11/27 as last day for indexes. For stocks they show 11/29.

1575148966754.png
 

status1

Member
I didn't realize you are looking at paper money
The charts on paper money are at 11/27 for me too but on the live trade it's 11/29 so it may be a glitch with the paper money
You could also use the live trade to track your trade that way you avoid some of the glitches in the paper money
 

Michael B

Member
Thank you. I keep learning new things. Indeed when using the Live setup all is up to date, including charts.
Thinking more about it, it may be that charts were always one day old and I didn't notice as I only look at charts in TOS when doing some rudimentary backtesting with thinkback. When checking my positions I always have IB - Mosaic on one monitor and TOS on another and since the Analyze tab shows the current last price, it matched what the chart in Mosaic was showing and I never noticed the problem. I uncovered it yesterday when RUT option chains were messed up and Analyze tab didn't work at all for RUT. As the customer service person said, it looks like they really had some problems.
 
Top